const regex = /^(?!.*\[m{3}\].*\[a(?:\.a){3}\].*).*$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\[m{3}\\].*\\[a(?:\\.a){3}\\].*).*$', 'img')
const str = `[Time] [mmm] [DATA] [rule] [a.a.a.a]
[Time] [ppp] [DATA] [rule] [a.a.a.a]
[Time] [mmm] [DATA] [rule] [c.c.c.c]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}