$re = '/(.*)(EB([\s]{0,})[ 0-9]{7})/m';
$str = ' EB 67645 89';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);