import re
regex = re.compile(r".*Eventname 2.*\n")
test_str = ("<select id=\"filter_event_id\" name=\"filter_event_id\" class=\"inputbox chzn-done\" onchange=\"submit();\" style=\"display: none;\">\n"
" <option value=\"0\">Select Event</option>\n"
" <option value=\"113\">Eventname (RB113) (02-05-2015)</option>\n"
" <option value=\"104\">Eventname 2 (T104) (09-05-2015)</option>\n"
" <option value=\"109\">Eventname 3 (M109) (15-05-2015)</option>\n"
" <option value=\"99\" selected=\"selected\">Eventname 4 (M99) (24-04-2015)</option>\n"
"</select>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")