import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{4}|[0-9]{2})\\/(0?[1-9]|1[0-2])\\/(0?[1-9]|[12][0-9]|3[01]), ([AP])M([1-9]|1[0-2]):([0-5]\\d) - ([^:]*): ((?:(?!^([0-9]{4}|[0-9]{2})\\/(0?[1-9]|1[0-2])\\/(0?[1-9]|[12][0-9]|3[01]), ([AP])M([1-9]|1[0-2]):([0-5]\\d))[\\S\\s])*)";
final String string = "2012/12/1, AM12:21 - user1: entry1\n"
+ "2012/12/2, AM9:42 - user2: entry2END\n"
+ "2012/12/2, AM9:44 - user3: entry3_Line1_ContdWithFollowingLine\n"
+ "entry3_Line2_ContdWithABoveLine\n"
+ "entry3_Line3_ContdWithABoveLine\n"
+ "2012/12/4, AM11:48 - user7: entry4END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}