$re = '/(?:([a-zA-Z_$][a-zA-Z\d_$]*(?:\.[a-zA-Z_$][a-zA-Z\d_$]*)*)\.)?([a-zA-Z_$][a-zA-Z\d_$]*)/m';
$str = 'UnpackagedClass
somepackage.SomeClass
java.lang.Object
java.util.function.Function
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);