$re = '/(?<=\$)\d+(?![.\d])/m';
$str = '$33.92 - no match
$211 - match 211';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);