$re = '/([A-Z])\d\n\1\d\n\1\d/m';
$str = 'A1
A2
A3
B1
B2
B3
C1
C2
C3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);