re = /(?<=window.runParams = ){\w+}(?=;)/m
str = 'window.runParams = {};
window.runParams = {blablabla};'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end