$re = '/^[0-9]+(.[0-9]{3})?$/';
$str = '231212456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);