const regex = /([\/\C\N\V\G\I\])([\d*])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\\/\\C\\N\\V\\G\\I\\])([\\d*])', 'g')
const str = `/C[2] /C[2]d ads /C[22] color one tow /V[3] /N[2] /G[1] and then we all went along`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}