re = /(?<!https?:)\/\/(.+?)(?<!https?:)\/\//mi
str = '//https://stackoverflow.com///'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end