$re = '/^([+]31|0031|0)-?6(\s?|-)([0-9]\s{0,3}){8}$/';
$str = '0031642165086';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);