$re = '/^[A-Za-z]( ?[A-Za-z] ?)*$/';
$str = 'as gb fjdk fghd ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);