re = /'((?:\\.|[^'\\])*)'/
str = '\'SELECT * FROM TABLE WHERE COLUMN = \\\'text\\\'\' '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end