#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)^(?P<meta1s>(?:\[[^\]]+\])*)(?P<name>.+(?=\[))(?P<ep>(?:\[(?:(?:NC)?(?:OP|ED|SP(?:\d{2})?)\])|\[(?:\d{2}(?:(?:\.\d+)?(?:_v\d+)?)?)\]))(?P<metas>(?:\[[^\]]+\])*)(?P<others>(?:.*?))(?P<ext>\.(?:mkv|mp4|srt|ass))$"
Local $sString = "[VCB-Studio] Sword Art Online Alicization War of Underworld [11][Ma10p_1080p][x265_flac].mkv" & @CRLF & _
"[UHA-WINGS&RATH][Sword Art Online - Alicization -War of Underworld-][11][BDRIP 1920x1080 HEVC-YUV420P10 FLAC].sc.ass" & @CRLF & _
"[Nekomoe kissaten][Do It Yourself!!][04][1080p][JPSC].mp4" & @CRLF & _
"[UHA-WINGS&VCB-Studio] Kobayashi-san Chi no Meidoragon S [NCOP][Ma10p_1080p][x265_flac].mkv" & @CRLF & _
"[Hakugetsu&VCB-Studio] No Game No Life [SP03][Hi10p_1080p][x264_flac].mkv" & @CRLF & _
"" & @CRLF & _
"(UHA-SGNIW) NoSQL [SP06] the anime [loolol] (LLLKKK) [SP99] ilikexd [speranza].mkv"
Local $sSubst = "\g<meta1s>\g<name>\g<ep>\g<metas>[SOX Edition]\g<others>\g<ext>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)