$re = '/\bopt[123]\s(?!\s*opt\d)(.*?)\s*\bbecause_of_this\b/m';
$str = 'other text opt1 opt2 opt3 I_want_only_this_text because_of_this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);