re = /(\w+ (?=\(\d))(\([\d,]+\))/m
str = 'Lorem ipsum dolor sit amet (12,16) , consectetur 23 adipiscing elit. Curabitur (45) euismod scelerisque consectetur. Vivamus aliquam velit (46,48,49) at augue faucibus, id eleifend purus egestas. Aliquam vitae mauris cursus, facilisis enim condimentum, vestibulum enim. Praesent'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end