const regex = /^(mongodb:(?:\/{2})?)((\w+?):(\w+?)@|:?@?)(\S+?):(\d+)(\/(\S+?))?(\?replicaSet=(\S+?))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(mongodb:(?:\\\/{2})?)((\\w+?):(\\w+?)@|:?@?)(\\S+?):(\\d+)(\\\/(\\S+?))?(\\?replicaSet=(\\S+?))?$', 'gm')
const str = `mongodb://username:localhost:27107/adfaeadf
mongodb://username:@localhost:27107/adfaeadf
mongodb://:password@localhost:27107/adfaeadf
mongodb://:@localhost:27107/mydatabasename
mongodb://@localhost:27107/mydatabasename
mongodb://localhost:27107/mydatabasename
mongodb:username:password@localhost:27107/mydatabasename
mongodb://someUser:abc123@server-a1.host.com:41652/testdb?replicaSet=rs-some2
mongodb://someUser:abc123@server-a9.host.com:41653,server-a2.host.com:41652/testdb?replicaSet=rs-some2
mongodb://localhost:27017/test
mongodb://:x@localhost:27017/test
mongodb://127.0.0.1:27017`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}