package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{4}`)
var str = `2016-04-28T00:00:00+00:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}