$re = '/[0-9]{3}(x|х)[0-9]{2}/ismu';
$str = '190х20
190х20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);