package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"contractNr\":\s+\"(?<contractNr>\d+)\",\s+\"cuid\":\s+\"(?<cuid>\d+)\",\s+\"action\":\s+\"(?<action>[^\"]+)\"`)
var str = `"contractNr": "1111111", "cuid": "222222", "action": "Remove"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}