package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Status: (.*?),(.*?)\s`)
var str = `Status: In-Progress,Updated
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}