$re = '/(?<!<br>)\n/';
$str = '1002;string1<br>
string2<br>
string3
1003;string1<br>
string2<br>
string3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);