$re = '/(?!.*-)(?=.*\d)^.+$/m';
$str = 'abc
abc1-
abc1
abc-abc1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);