$re = '/\w+ \w+\[-?\d+]/m';
$str = '" ## BATTERY LIFE: Pretty medicore at 12 hours, the Creative, iAudio, Rio, and iRiver players last longer.
CUSTOMER SERVICE[-3]## CUSTOMER SERVICE: Awful. Listen to this one, remember the battery statement I made earlier.
##If your battery dies and it\'s still under warranty, guess what, you\'re out of luck, because Apple doesn\'t cover the battery in the iPod warranty.
##They have the nerve to charge you $30 for a warrantied iPod.
technical service[-3]## "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);