// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(..[^^].{4,22}\$|[^?]+\w)$|2").unwrap();
let string = "PPCG
[^?][PG]$
(?<!\\\\..)(?!]).$
^[\\w^]*$|!|]P|G]\\$$
!|[^?]P(CG|G..)?$
[^])]\\$|^\\^?P|P.\\].$
([.$?]|G\\])\\$$|^\\^?P|\\]P$
([P.$?]\\$|[]^]P|G\\]\\$|CG)$
!|((G.|P|\\.)\\$|[^?]P|CG)$
^[(!P]|G..$|]..\\||[^?]P$
^[P^]P
^.{3,23}[.-~]..\\$$|[^P?][PG]$
^P
[PPCG]
^[P\\^]
[^\\]]$
^\\^?P
[^?][PG]$|<|PG
^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]$
^(.{,4}|.{9}|.{16,19}|.{5}P)$
^[^?]*[PG]$|[?$].*\\$$
^[^[]P|]P|(G]|[.])\\$$
\\..$|!|\\|G|^[\\^P]P|P\\^|G.\\$$
...\\^.P|^!|G]\\$$|w|<!|^\\^?P
([^\\\\}<]{3}|][^]]|^).?[$PG]$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}