$re = '/(?P<key>\w+)=(?P<value>[^,]+)/';
$str = '\'...abcd=123-456-ABC,email=hello@world.com,...\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);