const regex = /s,(^[0-9]+.(?:[0-9]+)+\;+)+|(^[0-9]+.\;)+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s,(^[0-9]+.(?:[0-9]+)+\\;+)+|(^[0-9]+.\\;)+', '')
const str = `900100003,;900100007,;900100111,;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}