re = /(\d+)(?!.*\d)/
str = 'http://radio-pendimi.com/website/index.php/artikuj/31-miresjellja-edukata-fetare/51-permbaje-gjuhen-tende'
# Print the match result
str.match(re) do |match|
puts match.to_s
end