using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"voyage\/(.+)\/(.+)\/";
string input = @"voyage/asie/emirats-arabes-unis/dubai/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}