$re = '/(?<!<a>)\d{3}(?!<\/a>)/';
$str = '<a>333</a> blah blah <b>234</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);