$re = '/^([\w]+(#[\d])*\.)+[\w]+$/m';
$str = 'document.info.userId
document.role#0.id
document.in#1fo.userId
document#1.creati#1onInfo.userId';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);