$re = '/^(?:([abcd])(?!.*\1)){1,4}$/m';
$str = 'bdca
adb
abcg
aab
abca';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);