$re = '/#(.*\n)/m';
$str = '1.
2.
3.
4. Test data 1
Please identify the ID number:
# 1016108
Please check if the number above matches the number below. The comparison result
should be "True or False". You should only compare the 7 digits:
a. #1016108
Please try to compare the results from Google OCR Engine and Microsoft OCR Engine.
And choose the one that suits for this task better.
Here is a third number # 123456, please DO NOT use this number for this task';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);