#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\*.*$"
Local $sString = "*> \author Univ. of Tennessee" & @CRLF & _
"*> \author Univ. of California Berkeley" & @CRLF & _
"*> \author Univ. of Colorado Denver" & @CRLF & _
"*> \author NAG Ltd." & @CRLF & _
"*" & @CRLF & _
"*> \ingroup realOTHEReigen" & @CRLF & _
"*" & @CRLF & _
"* =====================================================================" & @CRLF & _
" SUBROUTINE SBDSVDX( UPLO, JOBZ, RANGE, N, D, E, VL, VU, IL, IU," & @CRLF & _
" $ NS, S, Z, LDZ, WORK, IWORK, INFO)" & @CRLF & _
"*" & @CRLF & _
"* -- LAPACK driver routine --" & @CRLF & _
"* -- LAPACK is a software package provided by Univ. of Tennessee, --" & @CRLF & _
"* -- Univ. of California Berkeley, Univ. of Colorado Denver and NAG Ltd..--"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")