re = /^(?!(0|1|2|3|4|5|6)\b).*/m
str = '0
1
2
3
4
5
6
7
8
9
10
11
7 this is a test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end