$re = '/\d+(?= year(?:s)?)/m';
$str = '1 years, 2 months, 22 days';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);