package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:from)\s((?:0[1-9]|[12][0-9]|3[01])-(?:0[1-9]|1[1,2])-(?:19|20)\d{2})\s(?:to)\s((?:0[1-9]|[12][0-9]|3[01])-(?:0[1-9]|1[1,2])-(?:19|20)\d{2})$`)
var str = `from 10-08-2024 to 12-08-2024`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}