re = /(^\w*[ а-яА-Яa-zA-Z:,\/()]*\\?$)|^\\*[\w .:]*\\*\/?(.*)/m
str = '\\\\\\\\atxr2.atxr.ru\\\\_resource_test_001001\\\\_dir1
c:\\\\_resource_test_001001\\\\_dir1
\\\\atxr2.atxr.ru\\_resource_test_001001\\_dir1
D:\\
_dir1
\\\\atxr2.atxr.ru\\_resource_test_001004
Локальное имя
_resource_test_001004
Разделяемое устройство
atxr.ru/Users/Administrator
atxr2.atxr.ru/_resource_test_001004
atxr2.atxr.ru\\_resource_test_001004
Удаление,Смена владельца документа,Смена владельца,Удаление документа,Просмотр разрешений документа,Просмотр разрешений,Управление документами,Управление принтером,Просмотр документов,Печать,Установка разрешений документа,Установка разрешений
Подразделение Active Directory
atxr.ru/_resource_test_0011015/_resource2_test_0011015
atxr.ru/_resource_test_0011015/_user1_test_0011015
Содержание папки/Чтение данных,Чтение дополнительных атрибутов,Обзор папок/Выполнение файлов,Чтение атрибутов,Чтение разрешений
Чтение разрешений (подкаталоги),Чтение дополнительных атрибутов (файлы),Содержание папки (каталог),Чтение
атрибутов (подкаталоги),Чтение данных (файлы),Чтение атрибутов (файлы),Чтение дополнительных атрибутов (каталог),Чтение разрешений (файлы),Чтение
атрибутов (каталог),Чтение разрешений (каталог),Чтение дополнительных атрибутов (подкаталоги),Содержание папки (подкаталоги)
(^[\\w а-яА-Я:]*\\\\?$)|(^[A-Z]{1}:\\\\$)|^[\\\\a-zA-Z0-9.-:]*[\\\\\\/](.*)
(^[\\w а-яА-Я:]*\\\\?$)|^[\\\\a-zA-Z. :0-9-]*\\\\\\/?(.*)
(^\\w*[ а-яА-Яa-zA-Z:,\\/]*\\\\?$)|^\\\\*[\\w .:]*\\\\*\\/?(.*)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end