$re = '/^(?=79)\d{9}$/';
$str = '794567423';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);