re = /\n(?=Leistung\b)/m
str = 'Leistung Armeotraining ET Anzahl 1
Zusatz *TextZusatz_Anf1*
Leistung Atemtherapie 30 Anzahl 2
Leistung Aktivierungsgruppe Anzahl 3
Zusatz *TextZusatz_Anf3*'
subst = '\\n\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result