import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,7}(?:\\.\\d{1,2})?$";
final String string = "1\n"
+ "1234567\n"
+ "1234567.1\n"
+ "1234567.12\n\n"
+ "12345678\n"
+ "1234567.123\n"
+ ".\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}