$re = '/<span.*data-.*="(.+\n.+)/m';
$str = '<span data-clipboard-text="advocaciamdc.com
adunsg.com
adogstails.com
AdmissionZilla.com
AcehReseller.com"></span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);