const regex = new RegExp('\\b([A-Za-z]+\\s*\\([A-Z]+\\)|[A-Z]+)(\\s*-\\d+(?:,\\s*-\\d+)*)(?:,\\s*and\\s+(-\\d+))?', 'gm')
const str = `The acnes stimulated the mRNA expression of interleukin (IL)-1, -8, LL-37, MMP-1, -2, -3, -9, and -13 in keratinocytes.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}