re = /^\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}\.\d{3}Z$/m
str = '2022-08-15T13:43:24.376Z
2020-05-12T23:50:21.817Z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end