$re = '/^(?=(?:\([^()]+\)|[^()]+)$)\(?[a-z]+\)?$/m';
$str = 'abc
(anbv)
jh)
(nj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);