$re = '/(?<=\=\').*(?=\';S)/m';
$str = 'ICY Info: StreamTitle=\'Elvis Presley - Saved\';StreamUrl=\'\';
ICY Info: StreamTitle=\'Elvis Presley - Saved\'
ICY Info: StreamTitle=\'Ivank\'av T\'ali - Yorua\';StreamUrl=\'\';
ICY Info: StreamTitle=\'Ivank\'av T\'ali - Yorua\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);