$re = '/(\/(es|it|de|pt|fr|ru|jp|id|pl|ro|tr))?\/((\w{3})_(\w{3}))?$/';
$str = '/favicon.ico
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);