import re
regex = re.compile(r"\b(?:happ+y+\s*b(irthda|da?)y+|HBD)\b(?:\s*to\s*([^\d\s]+))?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("happyyy birthdayy\n"
"happy bdy\n"
"happy hbd happy bdy happy birthday birthday happy hpy birthday\n"
"hapy birthday")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")