$re = '/^[^.]+\.[^.]+$/m';
$str = 'test.com
fun.test.com
lesh.test.com
domain.tld';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);